Dgraph running on Windows

(Ami Pandat) #18

Yeh I tried but it is showing address already in use.
Sorry I think this may be a silly error but I have just started with these things. So…

(Michel Conrado) #19

Change the addr and port. Or check what is using it.

btw, you can use https://play.dgraph.io/ tho. Just point to localhost:8080

(Ami Pandat) #20

But in play.dgraph.io mutations are not allowed. Anyway to resolve that issue?

(Michel Conrado) #21

You can change the addr target in Ratel.

(Ami Pandat) #22

Yes that I know…but except play.dgraph.io all addresses are not connecting to server. I have tried :8000 :8180 :8080 :9180

(Michel Conrado) #23

In “Dgraph server URL” you have to use the HTTP address and port of your Alpha.
Certainly it is 8080 (localhost) otherwise your Alpha is in trouble. I’ts not ready. Check your logs.

(Ami Pandat) #24

Ohkay… So how to check logs for alpha?

(Michel Conrado) #25

Your terminal show the logs.

(Ami Pandat) #26

Alpha is connected to port 5080 so I have entered url like http:localhost:5080…still it is not connecting

(Michel Conrado) #27

No, only 8080 port should be used on Ratel input field “Dgraph server URL”.
Check this docs to understand the ports. https://docs.dgraph.io/deploy/#ports-usage

8000 is to access Ratel itself.

Well, I thought you were using Windows oO

(Ami Pandat) #28

In windows it is showing same error. Well, I will see ports usage and will let you know if I find any error.
Btw Thanks a ton!

(Ami Pandat) #29

Play.dgraph.io is showing error that mutations are not allowed. Is there any way to resolve that error?

(Michel Conrado) #30

Play Dgraph points to our servers that contains sample datasets. In it the mutation process is prohibited. If you are receiving this error, it is a sign that you have not changed the address in the input field correctly.

Explain in detail what you are doing, all context. Only then can I have an idea of what to guide you.

(Ami Pandat) #31

Yaa so I am working on my thesis to distribute my clusters of graph. I found that DGraph is distributed database and I started using it. I have installed it first on windows by using docker but it was not working then I have installed it on ubuntu but still same error showing that localhost is not connecting

(Ami Pandat) #32

On ubuntu I have installed it by using curl command and then type dgraph-ratel only…thats how I have done.
So now can you suggest me how to deal with this error of localhost connection

(Ami Pandat) #33

In short, I am missing some steps at the time of initialization which reflects in ratel connection to localhost.

(Michel Conrado) #34

Well, I still do not understand your context. But I’ll summarize here what you need.

You need at least one Dgraph Zero and one Dgraph Alpha configured and running. If you have questions about commands, review the commands used in YAML for Docker. And you will have a sense of basic commands to start. Check https://docs.dgraph.io/get-started/

Dgraph Ratel UI needs to access the HTTP port and usually is 8080. The address must be accessible and the port must be accessible as well. Then analyze firewall and other parameters of your operating system in relation to this.

If you are using virtual machine, you need to check forwarding and so on. These things are outside Dgraph’s scope.

Having a Dgraph Alpha Group (Zero and Alpha) running. You can access it normally. There’s no secret. If you are trying to create an HA configuration for example, distributed. I recommend analyzing YAMLs of that type.

Below is a schematic of how a Dgraph distributed organization is.

(Ami Pandat) #35

OKay .I got your point. But I am just not able to connect it to localhost. I dont know why? From two days I am facing same error.

(Ami Pandat) #36

Wohooooooo… done…there was an error with alpha. now it is connecting… Thankkkk youuu so muchh…Happy Happy!:smiley::smiley::smiley::smiley:

No mutations allowed by server
(system) closed #37

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.