# Error: 8 RESOURCE\_EXHAUSTED

**URL:** https://discuss.dgraph.io/t/error-8-resource-exhausted/3588
**Category:** Dgraph
**Created:** [November 13, 2018, 1:03pm UTC](https://discuss.dgraph.io/t/error-8-resource-exhausted/3588 "2018-11-13T13:03:16Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![labs20](https://yyz1.discourse-cdn.com/flex007/user_avatar/discuss.dgraph.io/labs20/32/1310_2.png) [@labs20](https://discuss.dgraph.io/u/labs20)
#### Post date: [November 13, 2018, 1:03pm UTC](https://discuss.dgraph.io/t/error-8-resource-exhausted/3588/1 "2018-11-13T13:03:16Z")

</div>

Hi there.

Started to get the error as soon as I updated to 1.0.10. Its a fresh new database with re-generated data with the same source I was using before.

Error: 8 RESOURCE\_EXHAUSTED: Received message larger than max (6539721 vs. 4194304)

Any help?

---

<div class="post-metadata">

### Author: ![MichelDiz](https://yyz1.discourse-cdn.com/flex007/user_avatar/discuss.dgraph.io/micheldiz/32/11873_2.png) [@MichelDiz](https://discuss.dgraph.io/u/MichelDiz)
#### Post date: [November 13, 2018, 2:23pm UTC](https://discuss.dgraph.io/t/error-8-resource-exhausted/3588/2 "2018-11-13T14:23:00Z")

</div>

This is a gRPC error that appears when some limit is exceeded.

More details in [grpc/statuscodes.md at master · grpc/grpc · GitHub](https://github.com/grpc/grpc/blob/master/doc/statuscodes.md)

---

<div class="post-metadata">

### Author: ![mrjn](https://yyz1.discourse-cdn.com/flex007/user_avatar/discuss.dgraph.io/mrjn/32/775_2.png) [@mrjn](https://discuss.dgraph.io/u/mrjn)
#### Post date: [November 14, 2018, 2:48am UTC](https://discuss.dgraph.io/t/error-8-resource-exhausted/3588/3 "2018-11-14T02:48:47Z")

</div>

and this is at the receiving end, so can be fixed by increasing the limits at client side.
