# Problem is setting up multinode cluster

**URL:** <https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423>\
**Category:** Users\
**Created:** [May 2, 2019, 11:07am UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423 "2019-05-02T11:07:03Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![mohanajuhi166](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@mohanajuhi166](https://discuss.dgraph.io/u/mohanajuhi166)\
**Post date:** [May 2, 2019, 11:07am UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423/1 "2019-05-02T11:07:03Z")

</div>

I am trying to setup a . multinode cluster (3 zero and 3 alpha nodes)

First peer configuration below  
Zero configuration  
**ExecStart=/usr/local/bin/dgraph zero -o 1 --my \<vm\_ip\>:5081 --replicas 3 --peer \<zero\_ip\>:5080 --bindall=true --idx 2 --wal /var/run/dgraph/zw**

Alpha configuration  
**ExecStart=/usr/local/bin/dgraph alpha --my \<vm\_ip\>:7081 --lru\_mb 2048 --zero \<zero\_ip\>:5080 -p /var/run/dgraph/p -w /var/run/dgraph/w**

My logs  
**Error while joining cluster: rpc error: code = DeadlineExceeded desc = context deadline exceeded**

My ratel stops functioning and i cannot load the schema or make a query.  
Can anyone help me regarding this.

Thank you.

---

<div class="post-metadata">

**Author:** ![amanmangal](https://yyz1.discourse-cdn.com/flex007/user_avatar/discuss.dgraph.io/amanmangal/32/1249_2.png) [@amanmangal](https://discuss.dgraph.io/u/amanmangal)\
**Post date:** [May 2, 2019, 12:11pm UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423/2 "2019-05-02T12:11:00Z")

</div>

This might help [Set up dgraph cluster manually](http://discuss.hypermode.com/t/set-up-dgraph-cluster-manually/4417)

---

<div class="post-metadata">

**Author:** ![mohanajuhi166](https://avatars.discourse-cdn.com/v4/letter/m/839c29/32.png) [@mohanajuhi166](https://discuss.dgraph.io/u/mohanajuhi166)\
**Post date:** [May 2, 2019, 2:41pm UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423/3 "2019-05-02T14:41:18Z")

</div>

Also, another error is

**Error: rpc error: code = Unavailable desc = all SubConns are in TransientFailure,…ection refused**

---

<div class="post-metadata">

**Author:** ![MichelDiz](https://yyz1.discourse-cdn.com/flex007/user_avatar/discuss.dgraph.io/micheldiz/32/11873_2.png) [@MichelDiz](https://discuss.dgraph.io/u/MichelDiz)\
**Post date:** [May 2, 2019, 2:47pm UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423/4 "2019-05-02T14:47:41Z")

</div>

> [@mohanajuhi166](#):
>
> ExecStart=/usr/local/bin/dgraph alpha --my \<vm\_ip\>:7081 --lru\_mb 2048 --zero \<zero\_ip\>:5080 -p /var/run/dgraph/p -w /var/run/dgraph/w

You are not using the -o flag here ^ - Also the zero must have the port offset, 5081. Because you used the flag -o 1 when starting the zero instance.

> [@mohanajuhi166](#):
>
> Error: rpc error: code = Unavailable desc = all SubConns are in TransientFailure,…ection refused

Fix the commands, start from scratch and you’re good to go.

---

<div class="post-metadata">

**Author:** ![system](https://canada1.discourse-cdn.com/flex007/uploads/dgraph/original/2X/2/2b38fdece2abe5814f2e51bee69d1e67fc304b0a.png) [@system](https://discuss.dgraph.io/u/system)\
**Post date:** [June 1, 2019, 2:47pm UTC](https://discuss.dgraph.io/t/problem-is-setting-up-multinode-cluster/4423/5 "2019-06-01T14:47:44Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
