Ratel fails to authenticate caused by CORS error when calling /query

I’m running DGraph locally through docker compose. I now want to access my local DGraph Server from The Ratel UI. I already tried Brave Browser which did not work but Firefox does connect to my local http endpoint It just fails to authenticate. Ratel just prompts me to input a userId and password. I tried the dfault credentials groot and password but it doesn’t work.

This is my docker-compose.yml file:

    image: dgraph/standalone:latest
    container_name: dgraph
      - basenet
      - ./docker-data/dgraph:/dgraph
      - 5080:5080
      - 6080:6080
      - 8080:8080
      - 9080:9080
    restart: on-failure
    command: dgraph zero --my=zero:5080

    name: "sessions-network"

I tried inspecting the network request from Ratel to find out what causes the ui to fail and found out that I get a bunch of CORS related issues to the /query endpoint.
Is that intended our could that be the cause for the connection failure?

Are you using ACL? if not, you can ignore that one. Just let it empty and hit continue.

See this

Thanks for your answer. I have decided to use one of the example docker compose files from github but I’m also having isse with the new configuration.
I have created a new question addressing my new issue.

Is it possible to delete this question because it is not relevant anymore?

Your question can help others. Let it there. No problem.