Cannot set graphql schema on new setup

I’ve just set up a new graphql using docker-compose.

I’m using this config:

And I started that by running docker-compose up

I then have a schema file, called dgraphschema.graphql

It contains graphql syntax schema definitions.

When i use curl like so:
curl -X POST localhost:8080/admin/schema --data-binary '@dgraphschema.graphql'

All i get back is this:
Dgraph browser is available for running separately using the dgraph-ratel binary

I’ve tried zapping my dgraph installation by docker-compose rm but that didn’t help.

I feel silly for running into this problem, but i can’t seem to get a schema up and running?

That should work. Try pulling in the latest image, you might be having an old one.

Indeed i had an old image in my local cache.
I removed all old ones, and tried again.

Unfortunately it still doesn’t work, but this time due to whitelisting issues.

Seems like the docker-compose files in the repo don’t take IP whitelisting into consideration on alpha nodes. Can that be fixed in the repo? Or at least added as a comment that whitelisting needs to occur?

Essentially line 20 of the config file i listed should read:
command: dgraph alpha --my=alpha:7080 --lru_mb=2048 --zero=zero:5080 --whitelist

I tried it on my machine with the same file(without any modifications), it’s working fine for me. Is it working for you after the modification?

It worked fine for me after the modification.