Dgraph live fails on macOS Mojave

Moved from GitHub dgraph/5378

Posted by darkn3rd:

What version of Dgraph are you using?

v20.03.1

Have you tried reproducing the issue with the latest release?

yes

What is the hardware spec (RAM, OS)?

Hardware:

  • MacBook Air (Retina, 13-inch, 2018)
  • Processor: 1.6 GHz Intel Core i5
  • Memory: 16 GB 2133 MHz LPDDR3
    Operating System
ProductName:	Mac OS X
ProductVersion:	10.14.6
BuildVersion:	18G103

Steps to reproduce the issue (command/config used to run Dgraph).

Install

DGRAPH_VERS=v20.03.1
curl -sSf https://get.dgraph.io | ACCEPT_LICENSE="y" VERSION="$DGRAPH_VERS" bash

Bring up servers:

DGRAPH_HOST="localhost"
dgraph zero --my="$DGRAPH_HOST:5080" --idx 1 &
dgraph alpha --my="$DGRAPH_HOST:7080" \
  --zero "$DGRAPH_HOST:5080" \
  --lru_mb 2048 &

Verify 9080 working:

nc -nv 127.0.0.1 9080
dgraph increment --pred=counter.val.healthcheck

Run dgraph live:

dgraph live \
  -s 21million.schema \
  -f 21million.rdf.gz

Expected behaviour and actual result.

I tried this on Ubuntu 18.04, and works fine, but on macOS, I cannot get this work. If it shouldn’t work, because of resources or something, then I cannot easily tell this from the stacktrace.

The actual results:

[Decoder]: Using assembly version of decoder
I0506 14:11:30.752436   18700 init.go:99] 

Dgraph version   : v20.03.1
Dgraph SHA-256   : cbd3c7fd96d08f6b78259a10e03d70ab85a4afd3c9a4c68daac6358fe84a4b6e
Commit SHA-1     : c201611d6
Commit timestamp : 2020-04-24 13:53:41 -0700
Branch           : HEAD
Go version       : go1.14.1

For Dgraph official documentation, visit https://docs.dgraph.io.
For discussions about Dgraph     , visit https://discuss.dgraph.io.
To say hi to the community       , visit https://dgraph.slack.com.

Licensed variously under the Apache Public License 2.0 and Dgraph Community License.
Copyright 2015-2020 Dgraph Labs, Inc.



Running transaction with dgraph endpoint: 127.0.0.1:9080
While trying to setup connection: context deadline exceeded. Retrying...
2020/05/06 14:11:41 Could not setup connection after 1 retries
github.com/dgraph-io/dgraph/x.Fatalf
	/ext-go/1/src/github.com/dgraph-io/dgraph/x/error.go:114
github.com/dgraph-io/dgraph/x.GetDgraphClient
	/ext-go/1/src/github.com/dgraph-io/dgraph/x/x.go:788
github.com/dgraph-io/dgraph/dgraph/cmd/live.run
	/ext-go/1/src/github.com/dgraph-io/dgraph/dgraph/cmd/live/run.go:435
github.com/dgraph-io/dgraph/dgraph/cmd/live.init.0.func1
	/ext-go/1/src/github.com/dgraph-io/dgraph/dgraph/cmd/live/run.go:119
github.com/spf13/cobra.(*Command).execute
	/go/pkg/mod/github.com/spf13/cobra@v0.0.5/command.go:830
github.com/spf13/cobra.(*Command).ExecuteC
	/go/pkg/mod/github.com/spf13/cobra@v0.0.5/command.go:914
github.com/spf13/cobra.(*Command).Execute
	/go/pkg/mod/github.com/spf13/cobra@v0.0.5/command.go:864
github.com/dgraph-io/dgraph/dgraph/cmd.Execute
	/ext-go/1/src/github.com/dgraph-io/dgraph/dgraph/cmd/root.go:70
main.main
	/ext-go/1/src/github.com/dgraph-io/dgraph/dgraph/main.go:78
runtime.main
	/usr/local/go/src/runtime/proc.go:203
runtime.goexit
	/usr/local/go/src/runtime/asm_amd64.s:1373

MichelDiz commented :

That feels like this issue https://github.com/dgraph-io/dgraph/issues/4019