Dgraph v1.1.0-rc1 release candidate


(Daniel Mai) #1

Hey folks,

Please try out our latest release candidate v1.1.0-rc1. If you find any issues, please let us know so we can address them before the final v1.1.0.

The full list of changes for v1.1.0 is available in the CHANGELOG. There are LOTS of significant changes and features in this version. They’re all covered in the CHANGELOG, so please take a look and let us know what you think! Dgraph v1.1 is NOT backwards compatible with Dgraph v1.0.

Link to binaries: Linux, Darwin, Windows.

Also published on Docker tagged as v1.1.0-rc1.

Note: This is not the official release. You won’t be able to get these binaries using the get.dgraph.io quick install script.

$ dgraph version

Dgraph version   : v1.1.0-rc1
Commit SHA-1     : e63b85b8
Commit timestamp : 2019-08-09 13:31:36 -0700
Branch           : HEAD
Go version       : go1.12.7

Cheers,

The Dgraph Team


(Boris V) #2

Hi, not sure if this is a bug or just me not reading it right in changelog:

  • Breaking change Remove _predicate_ predicate and expand() in queries. (#3262)

Does this means expand(_all) no longer supported in queries after v1.1.0?
As I tried on latest docker image: v1.1.0-rc1 and expand(all) is simply ignored in the query.


(Michel Conrado) #3

No, this is a kind of typo. Expand All still works. But you need to set the Schema Type to work.


(Daniel Mai) #4

Hey @bgv to enable expand() queries in v1.1 you’ll need to set the node’s type in the schema using v1.1’s type system. The expand function picks up which edges to expand by the node’s type.


(Dody Gunawinata) #5

Importing the test data from https://tour.dgraph.io/moredata/1/ generates a lot of errors. This is based on empty DB.


(Michel Conrado) #6

I had no issues by using master tour. You need to use the schema in master.
https://tour.dgraph.io/master/moredata/1/#


(Dody Gunawinata) #7

Ah got it. It works now.


(Dody Gunawinata) #8

Now that _ predicate _ is removed, what’s the replacement?


(Michel Conrado) #9

For now, there’s none. But We plan to do something similar. But you have the Schema Types now.


(Dody Gunawinata) #10

I encounter more problems with the imports

This is on windows 10 with fresh install.


(Michel Conrado) #11

Are you starting Dgraph from scratch? I never saw that error before happening in live load.
Please, if you can reproduce this error again fill up an issue in Dgraph repo with details to reproduce it.


(Dody Gunawinata) #12

#13

Hi,

When working with the demo data (1million.rdf.gz), I issue the following query and it does not seem to expand. I only get the uids. Am I doing something wrong?

{   all(func: allofterms(name@en, "The Secret Life of Words"), first: 10)                                                                                                                                   
  { starring @facets                                                                                                                                                                                        
    { uid expand(_all_) { uid } }                                                                                                                                                                           
  }                                                                                                                                                                                                         
}

(Michel Conrado) #14

To be able to expand you need to add Type Schema. Check the docs for the new Type System https://docs.dgraph.io/master/query-language/#type-system

Also if you’re using Dgraph 1.1 you need to set the tour to Master
https://tour.dgraph.io/master/moredata/2/

ALSO need the dataset from master.

wget "https://github.com/dgraph-io/tutorial/blob/master/resources/1million.rdf.gz?raw=true" -O 1million.rdf.gz -q

#15

Hi Michel,

I did add the type schema and set the tour to master. All other expand directives work except for that one for some reason.

It may actually be that predicates with a period did not load correctly or that predicates with a period are not being retrieved. I am testing further.


(Michel Conrado) #16

There are some typos in your query, that aren’t needed. This level of query doesn’t have Facets. Also you don’t need to use the param “first: 10” for this case (specific). Cuz there are no other nodes with the same sequence of terms. If the sequence were “The Secret Life” you would have 27 nodes. But “The Secret Life of Words” has only one.

He’s a clean query

{   
  q(func: allofterms(name@en, "The Secret Life of Words")){ 
  starring { 
    uid expand(_all_) { 
      uid 
    } 
  }
  }
}

Check if this query below works, if so maybe there’s something wrong with the dataset. I’ll check it.

{   
  q(func: allofterms(name@en, "The Secret Life of Words")){ 
  starring { 
          performance.actor { uid } 
          performance.film { uid } 
          performance.character { uid }
          performance.special_performance_type { uid }
  }
  }
}

UPDATE:

BTW, did you used the dataset 1million.rdf.gz from master? you need, cuz in the dataset there’s “dgraph.type” needed in the Type System.

wget "https://github.com/dgraph-io/tutorial/blob/master/resources/1million.rdf.gz?raw=true" -O 1million.rdf.gz -q

#17

I did use the 1million.rdf.gz from master. The first query didn’t work, but the second did. I think it might be the dataset. I searched for ‘<dgraph.type> "Performance’ (without single quotes) in the file and could find anything. I found types for most others.


(Michel Conrado) #18

humm, okay.

To confirm this can you do an upsert query for me? and redo the expand query.

Note that if you have 21million this query can be costly

curl -H "Content-Type: application/rdf" -X POST localhost:8080/mutate?commitNow=true -d  $'
upsert {
  query {
   q(func: has(starring)) { 
     starring {
         v as uid
       }
  }
}

  mutation {
    set {
      uid(v) <dgraph.type> "Performance" .
    }
  }
}
' | jq

#19

After the upsert, the expand query does now work. Thanks!