Duplicate zero and alphas in v20.03.1

Not sure if something changed with v20.03.1 or something is broken with my setup.

I’m not using docker, I’m running dgraph directly on Ubunutu. I downloaded / installed via

curl -sSf https://get.dgraph.io | bash

They are being run via systemctl. On the previous version of dgraph (v1.2.3) I ran

systemctl start dgraph dgraph-ui 

And dgraph, dgraph-zero, and dgraph-ratel would all start, this worked great for a month or more.
The Ubuntu settings for this haven’t changed, but after the latest dgraph upgrade (again using get.dgraph.io | bash) when I start the services I see that there are now two dgraph alphas AND two dgraph zeros are running.

Is this something new and should be expected?

With my current development / non-production environment I would assume 1 dgraph alpha and 1 dgraph zero is all that would be needed. If I understand the docs correctly multiple alphas are for sharding and multiple zeros are for high-availability. My current issue of 2 of each shouldn’t cause issues should it?

Yes. With v20.03.0 onwards, we have enabled Sentry reporting of panics seen in the Dgraph application. https://dgraph.io/docs/master/howto/#using-the-dgraph-sentry-integration
As a result, you will see 2x the number of instances of Alpha and Zero and the dupe instances are just simple monitoring processes for reporting events. This should not cause any issues.

From v20.03.1, You can also turn off this behavior by setting the enable-sentry=false option for the alpha and zero instances.

1 Like