Edge naming style

Is it bad style to set the predicate name of an edge to the node that it’s pointing to?
For example, if I have a company node and an employee node (of type “employee”).
This company node can have an edge pointing to an employee node.
The name of this edge is “employee”.
Is this okay?

A reasonable standard I can share on naming conventions is here. Here is the snippet on naming conventions for edges / predicates.

Name all properties as verb senses (so that triples may be actually read); e.g., hasProperty. Try to use **mixedCase** notation for naming these predicates.

So hasEmployee sounds better than just employee.