Error while importing data: Error while mutating Uid: [4600006] cannot be greater than lease: [0]


(Eelco) #1

Hi,

I’m importing RDF data into an empty dgraph v1.0.16 instance. Previously I would be able to import the same data into an older dgraph version without a problem (not sure what version but it was several months ago since I imported the data before).

I’m getting the following error:

Error while mutating Uid: [4600006] cannot be greater than lease: [0]

and so forth and so forth…

Any idea on how to resolve this issue?

Thanks,
Eelco


(Eelco) #2

Oh, I tried the hint from this topic: Uid: [24387] cannot be greater than lease: [0]

But

curl http://zero:6080/assign?what=uids&num=10000000

results in

{"errors":[{"code":"ErrorInvalidRequest","message":"num not passed"}]}

(Eelco) #3

Fixed this…

The problem was that I applied the schema I wanted to use before importing the data. When I applied the schema within the import command everything worked fine.


(Manish R Jain) #4

This looks like a bug. @MichelDiz please investigate.

I meant the num not passed error.


(Michel Conrado) #5

The issue is related to Curl, you need to add quotation marks to the addr.

Running via Chrome works fine
Captura%20de%20Tela%20(14)

Running without quotation marks and with.