How set dgraph on Apple Silicon arm64

I’m trying to setup the dgrpah locally on Apple Silicon Mac books but I’m keep getting following errors.

WARNING: The requested image’s platform (linux/amd64) does not match the detected host platform (linux/arm64/v8) and no specific platform was requested

Please share any docs on setting up dgraph on arm64 machines.

Thanks

The M1 isn’t supported for now. There is a build from the community that might work. Not sure if it is available on Brew or something else. I saw a conversation about it.

Ping @chewxy and @joaquin.

I’d really appreciate if I get access to even beta release.

Look’s like Go’s latest release (1.16) now has support for arm64 :slight_smile: https://blog.golang.org/go1.16 (was released like 12hrs ago)

Not sure if this means anything or not lol… but figured i’d post anyway :wink:

Well, I tried that but still complains about image’s platform. However I saw something on docker docs about adding –platform linux/amd64 but it looks like images has to be build with that flag. Dgraph team is my only hope :crossed_fingers:t3:

I was able to run docker commands without crashing but getting following error.

I tried docker steps from here - https://dgraph.io/docs/deploy/single-host-setup/

17 groups.go:1143] Error during SubscribeForUpdates for prefix “\x00\x00\vdgraph.cors\x00”: Unable to find any servers for group: 1. closer err:

@mrjn