Ratel refusing to connect unless I'm in incognito mode


This is working on a project on my local machine, for now.

When connecting to ratel, the first thing I see is the “dgraph server connection” screen, with “localhost:8080” selected by default.

I have several databases running with docker compose, and have the ports exposed in sequential order, so “8081:8080”, “8082:8080” etc.

But when I type “localhost:8081” in the “Dgraph servel url” box and click “connect”, the screen appears to refresh then the “localhost:8081” option has disappeared.

What’s curious is that if I do the same thing in incognito mode, it successfully connects to localhost:8081 and I can run queries. This suggests some problem in cache or settings or something, right?

But my colleague, who has started on a brand new computer, is experiencing the same issue. Any ideas what we need to do?

I think you can try clearing your browser cache and cookies first. If the issue persists, check if there are any browser extensions or plugins that might interfere with the connection settings. Your local environment configurations are correctly set up and that there are no conflicts in the network or Docker configurations.Double-check port mappings in Docker Compose to ensure they are correctly exposing the ports needed for Dgraph.