Rename "GraphQL Vars" to something else

Over time I noticed that people confused GraphQL Variables a lot with GraphQL itself even when we hadn’t any GraphQL support. This generates a little confusion and maybe the disuse/misuse of the feature. It would be interesting to rename it even because we have support for GraphQL natively and this can be confused with the variable that GraphQL itself has.

Maybe DQL Vars?

I almost think that query variables be renamed to block variables and the graphql variables be renamed to query variables. I would also group all the variable docs together. Right now the value and query variables are listed together with graphql variables near the bottom of the list.

1 Like