ResourceExhausted error in grpc

Hi, I’m using golang driver and getting error when load bulk data.

2020/03/04 20:17:17 rpc error: code = ResourceExhausted desc = grpc: received message larger than max (4729171 vs. 4194304)

4194304 = 1024 * 1024 * 4 = 4MB
but, I pushed more than that.
How can I change default max size? There is nothing documentation that mentions about it.

[self-answer]

grpc.WithMaxMsgSize() function can adjust max size and I used it and then solved the problem.

See : https://github.com/grpc/grpc-go/commit/d19bbe846e809da62d36f3c9df469e6736be9693

If it is possible, please fill up an issue. So we can add a flag for that.

minor update:

Dgraph’s Max msg is 4GB see the links bellow.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.