Using ratel on local Kubernetes cluster

I’m trying to use ratel with an install in a local k8s cluster but even if it says it’s connected it doesn’t work.

$ kgp
NAME                            READY   STATUS    RESTARTS   AGE
dgraph-ratel-794ccf7b56-gzvzb   1/1     Running   0          33m
dgraph-zero-0                   1/1     Running   0          33m
dgraph-alpha-0                  1/1     Running   0          33m
dgraph-zero-1                   1/1     Running   0          33m
dgraph-alpha-1                  1/1     Running   0          33m
dgraph-zero-2                   1/1     Running   0          32m
dgraph-alpha-2                  1/1     Running   0          32m
$ kpf services/dgraph-ratel-public 8000:8000
Forwarding from -> 8000
Forwarding from [::1]:8000 -> 8000
kpf services/dgraph-zero 5080:5080
Forwarding from -> 5080
Forwarding from [::1]:5080 -> 5080

When I try to use ratel even if it says “connected” on the login window it doesn’t work and complain after that. In the developer console I see

clientStub.js:634   POST http://localhost:8080/query?timeout=20s&debug=true

Does it need anything else ? is it said in the documentation somewhere ?


You don’t need to forward Zero instances. Just Alphas. The port is 8080. Or 9080 if gRPC.

Same issue even with those port forwards:

When you say GRPC Vs HTTP I suppose I need to expose GRPC if I use a different client than ratel ?

Based on the error I see in the console I tried this and it failed. I hope it helps figuring out what’s going on, cause I see nothing in ratel logs …

http GET http://localhost:8000/health
HTTP/1.1 404 Not Found
Content-Length: 32
Content-Type: text/plain; charset=utf-8
Date: Sun, 27 Nov 2022 15:54:41 GMT
X-Content-Type-Options: nosniff

Asset not found for path health

FYI I installed the cluster using helm install dgraph dgraph/dgraph --set image.tag=latest --set ratel.enabled=true --set ratel.image.tag=latest

Yes. Ratel uses HTTP calls. Any other client uses gRPC.

There’s no health in Ratel. This port is from Ratel.

Change to http://localhost:8080/health

Thanks, I see where he issue came from. Instead of provide the url of the alpha in ratel I was providing the url of ratel itself :man_facepalming