V20.11-rc1 version, ratel got an error

Unsupported Content-Type. 
Supported content types are application/json, application/graphql+-,application/dql

Hi @Valdanito, Can you please specify what query/mutation you ran or if you use Curl command then what was the Content-Type ??


default query request header is text/plain.

When I run a query, I need to add the request header of dql or graphql±, and the request header of json will get the same error.

No problem with state and health requests.

This is the bug related to ratel when it’s not able to find a version of the running dgraph instance. It happens when git information is not available for the dgraph instance, for example when you directly download source code instead of git clone.
If you clone dgraph and go to release tag by git checkout release/v20.11-rc1, then you will be able to use ratel.

@dmai, i guess we should have a fix for this so that version number or other information is made available to ratel by other means.

1 Like