Why is port 7180 not open and the server has no restrictions on ports

Why is port 7180 not open and the server has no restrictions on ports

the logs:

You have set the port_offset to 100 which means that all the ports(grpc/http) for zero will be at offset 100 from their default value of 5080/6080 respectively.

Yeah, I agree that --my flag must have thrown some warning. I would suggest to use --port_offset.

-my IP: Port didn’t work?Request 7180 from other zero nodes in the same cluster was rejected

Hey @tss, this is a known issue which is filed here: Dgraph alpha's --my flag doesn't work correctly - #10 by diggy, similar issue is with zero.

the --my flag is currently used to specify the IP:port only (not setting it) and the port is set by the port_offset flag.

remove port_offset, -my didn‘t work. I’d better use the default configuration. It took a long time, I have more questions to ask. Please wait a moment!

We are sorry for your experience, the team will get this fixed soon. For now, if you want your grpc to run on 7180, then you can run the following command:

dgraph zero --idx 101 --my=IP:7180 --port_offset=2100 --wal ../data/zw --replicas 3`

Have you ever encountered this problem when setting up a dgraph zero cluster? The zero nodes can’t join the cluster

ip: ##:##:##:34

ip: ##:##:##:159

Hey, can you show the commands you ran for the running zero cluster?
For running locally, I have these commands

dgraph zero --idx 10 --port_offset=100
dgraph zero --idx 20 --port_offset=200 --peer=

three are 3 zero nodes in one cluster.

the first(159):
./dgraph zero --idx 101 --my ##.##.##.159:5080 --wal …/data/zw --replicas 3

the second(34):
./dgraph zero --idx 102 --port_offset 100 --my ##.##.##.34:5080 --peer ##.##.##.159:5080 --wal …/data/zw --replicas 3

Can you try updating --my flag in second(34) to ##.##.##.34:5180? As you have set the offset to 100.

remove --port_offset 100, the same problem


That should have worked. Have you tried this after clearing the zw directories?

sorry i am new to dgraph, p、w、zw all need delete?


it works,thanks.can you tell me why i delete those files,it worked well?,and the another problem :
where alpha connect to zero,Alpha error log as follow:

To summarize my understanding of the --my and --port_offset flags:
--port_offset: The ports for grpc/http are specified as an offset to default ports(5080/6080 in case of zero).
--my: This flag specifies (not decides) the IP and port. This IP:Port data is used for communication. You don’t decide it. You specify it.

This worked after creating up the directories because the zw and w directories contain the data for raft. So the cluster might be using stale data to communicate.

Anyways, you can ignore the logs in the last message. It is just that there are multiple retries made for connection.

Alpha’s error log is always printed.Filled up my disk.i want to deal it