Dgraph-ratel binary missing in docker image v21.03.0

It looks like dgraph-ratel is missing in the latest docker image for v21.03.0.

Starting a docker container gives the following error:
starting container failed: OCI runtime create failed: container_linux.go:367: starting container process caused: exec: "dgraph-ratel": executable file not found in $PATH: unknown

Running the following command, shows the binaries in latest docker image compared to the previous. As you can see, dgraph-ratel is missing in v21.03.0. Is ratel going to be started differently?

$ docker run -it dgraph/dgraph:v20.11.2 ls -l /usr/local/bin
total 67672
-rwxr-xr-x 1 root root 11462920 Feb 23 07:58 badger
-rwxr-xr-x 1 root root 45126960 Feb 23 07:57 dgraph
-rwxr-xr-x 1 root root 12698992 Feb 23 07:58 dgraph-ratel
$ docker run -it dgraph/dgraph:v21.03.0 ls -l /usr/local/bin
total 60632
-rwxr-xr-x 1 root root 11997104 Apr  7 17:39 badger
-rwxr-xr-x 1 root root 50087280 Apr  7 17:38 dgraph

Yes, from now and beyond Ratel will be separated from the main image.

@MichelDiz as ratel has already been removed from the main image, can you point towards documentation for how to use ratel from a separate image? Looks like all official container stacks still reference the mail image as the source for ratel.

For now, use a previous image to run Ratel. Ratel uses CDN first, so it will be always updated. Just the local bundle that won’t.

Ping @dmai about what gonna happen.

1 Like

Maybe an idea to update the documentation, and references to dgraph-ratel in kubernetes deployment descriptors.

Keep up the great work.

1 Like

I just ran into this issue: Localhost:8000 connection refused - #6 by noisykeyboard

I looked through previous versions of the standalone image here—Docker Hub, but can’t figure out which version comes before 20.03.0 because the versioning strategy seems to have changed?

you can use play.dgraph.io

1 Like

@dmai @MichelDiz Running from play.dgraph.io is not an option for us since we run Dgraph from an airgapped environment. The removal of the Ratel UI from the Docker image just broke things for us.

See this PR

@joaquin has published the Ratel image Docker Hub

So what’s the final way to run Ratel now?

This one https://play.dgraph.io/

Using https://play.dgraph.io will not work for a dgraph running on http://example.com

Even with

Access-Control-Allow-Origin: *

You cannot cross the http/https, https/http boundary.

I solved with another docker container for ratel. The following is my docker compose.
Sorry for relocating the ports to 700x but I already have a busy 80xx

version: '3'
services:

  dgraph:
    image: dgraph/standalone:v21.03.1
    restart: always
    ports:
      - "7001:8080"
      - "7002:9080"
    volumes:
      - "./dgraph:/dgraph"
      
  dgraphratel:
    image: dgraph/ratel
    restart: always
    ports:
      - "7000:8000"

Hope this helps.

In order to double test it I tried also a reverse proxy on play. dgraph. io (sorry for these strange spaces) using a Caddy configuration.
But I cannot post the caddy conf because as a new user I cannot post more than two links and also play dgraph io count as a link.

Best