Do not include <type> in Bulk Edit schema

Moved from GitHub ratel/73

Posted by codexnull:

When I click on “Bulk Edit” to modify the schema, an editing frame is displayed with the current schema in it. Clicking “Apply Schema” after making my schema changes (or even before making any changes) results in the error “Could not alter schema: predicate type is reserved and is not allowed to be modified”. I have to delete the “type” predicate in order to “Apply Schema” to succeed.

Since “type” is now reserved and can’t be modified, it should either be excluded when presenting the current schema for modification or ignored when the schema is applied.

martinmr commented :

Same for the rest of the reserved predicates (so far just the ACL predicates).

paulftw commented :

Dgraph now ignores setting schema to reserved predicates as long as schema matches the currently active one