Error: unknown flag: --lru_mb when starting DGraph v21.03.0

To facilitate better answering of questions, if you have a question, please fill in the following info. Otherwise, please delete the template.

What I want to do

When I tried to start the DGraph, I got the following error. How could I solve it.
Error: unknown flag: --lru_mb
I have searched other discussions, but still not find any solutions.

What I did

[syy@master Project]$ /usr/local/bin/dgraph alpha --lru_mb 1024
Error: unknown flag: --lru_mb

Dgraph metadata

dgraph version
Dgraph version   : v21.03.0

Dgraph codename  : rocket
Dgraph SHA-256   : b4e4c77011e2938e9da197395dbce91d0c6ebb83d383b190f5b70201836a773f
Commit SHA-1     : a77bbe8ae
Commit timestamp : 2021-04-07 21:36:38 +0530
Branch           : HEAD
Go version       : go1.16.2
jemalloc enabled : true

For Dgraph official documentation, visit https://dgraph.io/docs.
For discussions about Dgraph     , visit https://discuss.dgraph.io.
For fully-managed Dgraph Cloud   , visit https://dgraph.io/cloud.

Licensed variously under the Apache Public License 2.0 and Dgraph Community License.
Copyright 2015-2021 Dgraph Labs, Inc.

Hi @duishuhaoqi,
You are using flags valid in version v20.x-. the new flag for cache size is documented here.

Can you share were did you get it? is it in our docs? tutorials? so we can fix it.

Cheers.

It’s actually on the main website (https://dgraph.io/downloads)… I have a PR coming

1 Like

I got it on https://dgraph.io/downloads

Thanks for your remind. But I cannot find the new superflag to replace --lru_mb and dgraph-ratel, where could I find them? Thanks for your help!

use --cache size-mb=1024

Dgraph Ratel is now a separate docker image