Tour intro does not implement new superflags

Report a Dgraph Bug

What version of Dgraph are you using?

Dgraph Version
$ dgraph version
 
Dgraph version   : v21.03.0
Dgraph codename  : rocket
Dgraph SHA-256   : b4e4c77011e2938e9da197395dbce91d0c6ebb83d383b190f5b70201836a773f
Commit SHA-1     : a77bbe8ae
Commit timestamp : 2021-04-07 21:36:38 +0530
Branch           : HEAD
Go version       : go1.16.2
jemalloc enabled : true

For Dgraph official documentation, visit https://dgraph.io/docs.
For discussions about Dgraph     , visit https://discuss.dgraph.io.
For fully-managed Dgraph Cloud   , visit https://dgraph.io/cloud.

Licensed variously under the Apache Public License 2.0 and Dgraph Community License.
Copyright 2015-2021 Dgraph Labs, Inc.

Have you tried reproducing the issue with the latest release?

Yes.

What is the hardware spec (RAM, OS)?

N/A

Steps to reproduce the issue (command/config used to run Dgraph).

Visit Run Dgraph | Intro | Dgraph Tour

Run the commands in the β€œUsing Docker Commands” section:

# Run Dgraph zero
docker run -it -p 5080:5080 -p 6080:6080 -p 8080:8080 \
  -p 9080:9080 -p 8000:8000 -v ~/dgraph:/dgraph --name dgraph \
  dgraph/dgraph:v21.03.0 dgraph zero

# In another terminal, now run Dgraph alpha
docker exec -it dgraph dgraph alpha --cache_mb 2048 --zero localhost:5080 --whitelist 0.0.0.0/0

Expected behaviour and actual result.

Expected: Dgraph Alpha should start.

Result: Error: unknown flag: --cache_mb, then Error: unknown flag: --whitelist.

Suggested change:

-docker exec -it dgraph dgraph alpha --cache_mb 2048 --zero localhost:5080 --whitelist 0.0.0.0/0
+docker exec -it dgraph dgraph alpha --cache size-mb=2048 --zero localhost:5080 --security whitelist=0.0.0.0/0

Thanks @elhil , for reporting this. It will be awesome if you can send a PR to fix this. GitHub - dgraph-io/tutorial: A Tour of Dgraph

Do let me know if you want to fix this as you also know the fix. :wink:

Will do!

1 Like