Got "v230/go.mod does not exist" when install

Report a Dgraph Client Bug

What Dgraph client (and version) are you using?

  • Dgo

Version: v230

Steps to reproduce the issue (command/config used to run Dgraph).

Just run

go get

It will show error

go:[email protected]: go.mod has non-…/v230 module path “” (and …/v230/go.mod does not exist) at revision v230.0.0

Renovate also failed to bump the version with same error:

This issue starts to happen from

Expected behavior and actual result.

Expect succeed installing new package, but failed

@Hongbo-Miao Please, next time you create an issue. Give it a meaningful title. Otherwise we will flag it as spam and delete it.

PS. I have edited the title.

Pinging @amanmangal and @joshua

Thanks @MichelDiz ! The title I was using is is exactly same with the error I met which I think is straightforward for other people to search and also for search engine to index. However, I have updated the title to be more human readable as request. :slightly_smiling_face:

Could you try again now? It should work, we had to retract the v230.0.0 release of dgo and we just did a release v230.0.1-rc1 for dgo

1 Like

For me this now works, also go get -u upgraded to this release, which wasn’t working before.

1 Like

Thanks @amanmangal

go get[email protected]

works now! :smiley:

1 Like