How to set Labels in Ratel UI


(Ami Pandat) #21

Aww…okay…Got it!
I will try this out!
Thanks:grinning:


(Ami Pandat) #22

Hey
I have already loaded JSON file using Bulk loader.
Now I want to load .rdf [which I have just created ]file by using bulk loader so will it overwrite previously loaded file?
I mean how will it react after uploading .rdf file by using bulk loader again?


(Michel Conrado) #23

You mean Live loader. So, it would overwrite if you set the UIDs on each node. If there’s only blank nodes, they’ll be loaded as new nodes.

You can’t use Bulkloader for a existing Dgraph.


(Ami Pandat) #24

Okay, then how to delete all the data which I have previously loaded by Bulk Loader?


(Michel Conrado) #25

You can use Drop All or delete /p, /w and /wz folders
https://docs.dgraph.io/deploy/#delete-database


(Ami Pandat) #26

Okay.
One more doubt,…I have read that after starting dgraph zero we have to load bulk loader and then dgraph alpha and dgraph ratel respectively. But what is the order for execution of dgraph live?


(Michel Conrado) #27

Dgraph Zero it’s like a “data balancer and manager”. Through it Dgraph perform several crucial tasks. BulkLoader needs access to Dgraph Zero so it will request the allocation of UIDs and other things. BulkLoader is ideal when you are starting a setup from scratch. And Bulkloader only works on that occasion.

So first Dgraph Zero and then Bulkloader.

However, Liveloader is designed to work with a running cluster setup.

So you need a cluster up and running. And then connect your Liveloader to this cluster.


(Ami Pandat) #28

Okay.
I am facing an issue with schema file when I use Live Loader. It is showing an error,

Error while processing schema file “Rdf_lodSchema.schema”: rpc error: code = Unimplemented desc = unknown service api.Dgraph
badger 2019/04/14 17:13:41 WARNING: While forcing compaction on level 0: Unable to fill tables

THis is my schema fileRdf_lodSchema.schema (765 Bytes)

I am not getting the issue.


(Michel Conrado) #29

Try to add angular brackets around those

<22-rdf-syntax-ns#type>

But using live load you don’t need a schema. For the DB is already running with a schema. Unless you wanna change it or add something.


(Ami Pandat) #30

I want to change the schema that is why I am trying to load this file.


(Ami Pandat) #31

Hey… Now schema is fine and data has also been loaded by live loader successfully but still the issue of labeling I mean naming is there.

See :point_up_2: still no labeling…Even not a single edge is displaying.


(Michel Conrado) #32

okay, @paulftw Can you help with this?


(Michel Conrado) #33

Until then, you can use this old version of Ratel. And use the “regex” for labels.


(Ami Pandat) #34

Okay I have installed it and tried to run a query

But still there is nothing like a label.
Can you tell me how to use regex for labeling?


(Michel Conrado) #35

Don’t use Alias and add the predicate in this input box.


(Ami Pandat) #36

When?
I mean after executing query?..right?


(Michel Conrado) #37

I mean after executing query?..right?

after


(Ami Pandat) #38

okay… I have done that.
Still no change in results :expressionless:


(Michel Conrado) #39

You’re doing something. That’s the only way. OR the type isn’t supported for Labeling (like UID) or the size is too much big. Or you’re typing wrong (check the Schema on Dgraph, not on .schema just to be sure.)


(Ami Pandat) #40

Okay . I think I should spend some time on background reading about schema and all.
Thanks!