Just deployed Dgraph Scaleway Dev-S instance and have a few questions about it

Hi, I just installed Dgraph on a Scaleway Dev-S instance for testing and it worked instantly… I was surprised that it is that easy :smiley:

Here are the commands I used:
nohup dgraph alpha --my=localhost:7080 --zero=localhost:5080 --lru_mb=1024 &
nohup dgraph zero --my=localhost:5080 &

Now I am all hyped and have a few questions:

  1. It seems that alpha listens on port 8080 for http requests. I want to run my web server on port 8080, can I change the port or disable http completely as i don’t plan to use ratel anyway.

  2. I can see an authentication form in ratel . How can I secure Dgraph.

  3. /admin/backup seems to be an enterprise feature. Can I manually backup the full database ? If so how can I do it.

  4. The most important question. I want to run Dgraph with an apollo node.js express server. I am not a hosting person but I am sure the above commands aren’t suitable for production usage :smiley: I was wondering, what has to be done to make Dgraph available for production usage.

Thanks!!

1 Like

You can’t disable it. But you can change its offset use --port_offset 2 https://docs.dgraph.io/deploy/#ports-used-by-different-nodes - all ports will increase by 2. eg: 7082, 5082 and so on.

You can use ACL (Enterprise) or just isolate Dgraph behind and API.

You can use https://docs.dgraph.io/deploy/#export-database it is similar.

which commands?

Just run it, create an API and done.

Cheers.

Michel, thanks again for your help!!!

I started Dgraph with below commands. I am asking because the speaker from the tour videos said, that the standalone docker image is for quickstart purposes and not meant for production usage. I don’t think I am doing anything different. That’s why I am wondering what I have to do.

nohup dgraph alpha --my=localhost:7080 --zero=localhost:5080 --lru_mb=1024 &
nohup dgraph zero --my=localhost:5080 &

Cheers

Don’t use the standalone image for production. Use the official one.

Good to know. Last question: Unfortunately my main Hosting is on Hetzner who doesn’t allow docker images. Can I run it without docker?

Yes, you can just download the binaries and use it in bare metal instances.

Hi there,
I ve just deployed aswell on scaleway dev-s ! ; )

Question I have is about the support of Dgraph’s versions :

How long 1.1.x will be supported ?
What will be the process to upgrade from 1.1 to 1.2 ?
Will we have a debian / ubuntu package as for regular databases ?

In an ideal world we would have little to do to update within the 1.X (like with postgres). Also I have already read somewhere that from 1.0 -> 1.1 you need to do a complet dump and reload … Which is less than ideal, especially if you are looking to run 10 nodes of dgraph :wink:

1 Like

supported by Dgraph? I think until 2.x.x (just guessing).

In general, if the version isn’t backwards compatible, you have to export and reimport. But we recommend always export and reimport.

Dunno, but I don’t think so. I guess the Linux bin works in all dists.

Congrats :slight_smile: I would be interested in hearing how you deployed it. Do you mind sharing :blush: