My dgraph standalone ratel take too long too response

To facilitate better answering of questions, if you have a question, please fill in the following info. Otherwise, please delete the template.

What I want to do

I just want to start running dgraph instance for the first time

Please list the high level idea of what you want to do

What I did

I try to run

docker run --rm -d -it -p 8080:8080 -p 9080:9080 -p 8000:8000 -v ~/dgraph:/dgraph dgraph/standalone:latest

when I enter chrome with my localhost:8000. I always get the request take too long to response.

Please list the things you have tried.

I tried using docker playground to check that its also having the same problem

Dgraph metadata

dgraph version

PASTE THE RESULTS OF dgraph version HERE.

The standalone doesn’t have Ratel binary.

Let me know if you have Ratel running and then I get a notion about what is happening.

Please, also share logs of the standalone run.

if that is the case how can I run ratel locally. I try to use the hosted version but the password:password that is suggested in Github issue doesn’t work.

Also, in the document, it suggests that I can use localhost:8000
https://dgraph.io/docs/get-started/

I understand that it uses a different docker image but it also doesn’t work.

Use this image Docker Hub

What hosted? play Dgraph?
If you are running Dgraph locally with no TLS Chrome will block the connection due to some new rules from Google engineers.

Thank you. I have it resolved by running the ratel from the docker hub.
However, please correct me if I am wrong, but I think your documentation needs to be updated.

Yep, we need to update some things indeed.