Get started page is not up to date

I was running an older version of dgraph standalone docker and it worked fine. Recently I have updated to the newest version and I haven’t been able to use it. After some searching, I have discovered that the ratel service was no longer available inside this docker.
This change hasn’t been mentioned anywhere, even on the getting started page it is stated:

This would start a single container with Dgraph Alpha , Dgraph Zero and Ratel running in it. You would find the Dgraph data stored in a folder named dgraph of your home directory .

I was able to find the solution only after searching here.
Please update the documentation, thanks :slight_smile:


I had made a recent change that fixes this for standalone (5 days ago). You can get all three of those (Dgraph Alpha, Zero, and Ratel) with this container: dgraph/standalone:v21.03.0. To verify that you have the right version, the repo digest should be: 51aa92019d16fa0482ecd2335a8efeb2d73837e2ea6655735e4245cfdd110541

You can verify with:

docker pull "dgraph/standalone:v21.03.0"
docker inspect "dgraph/standalone:v21.03.0" | jq -r '.[0].RepoDigests[]'

(Note: the example uses jq tool to extract desired key/value from JSON)

still doesn’t work:

/ line 16: dgraph-ratel: command not found
Dgraph version   : v21.03.1
Dgraph codename  : rocket-1
Dgraph SHA-256   : a00b73d583a720aa787171e43b4cb4dbbf75b38e522f66c9943ab2f0263007fe
Commit SHA-1     : ea1cb5f35
Commit timestamp : 2021-06-17 20:38:11 +0530
Branch           : HEAD
Go version       : go1.16.2
jemalloc enabled : true

use this image Docker Hub

The standalone will have all the binaries needed for the tutorial, so Ratel would need a separate docker command if not standalone. Currently the standalone, which should have Ratel, doesn’t have build scripts to include the binary. If I get a chance, I can look into fixing that, but this may not be soon.