Problem with joinning two filters

Hi team,I’m using Dgraph v1.2.2 since March this year. Everthing is ok but I stuck on an adhoc query today.

I tried to filter nodes which “owner” and “applicationType” are both expected, I tried to start a query on either and filter on the other, or start on “has(owner)” and filter both with and. none of these trials worked.

You may tell me to check my data, I check my data with starting on equal function and filtering with has function. when I replace has function with equal function on first result, nothing returns.

These are my trials, please help:

1 Like

This should be opened in the Dgraph category, not the GraphQL. As this is DQL related.

Please, considered an upgrade. At least to v1.2.8 which was released this week.

Does your data has the “dgraph.type”?

Please do a query with

  q(func ...) {

Just to check if this is related to the expand function. BTW, avoid using expand all, all the time. Make your queries more fixed/predictable. This makes things clear in your development flow.


Yes, My data has type.

I’ll try latest release latter. but I wonder whether this bug has been solved fundamentally, because last time I migrate 1.1.0 to 1.2.2 for similar reason.