PyDgraph client failed to connect to the cloud via endpoint

Report a Dgraph Client Bug

What Dgraph client (and version) are you using?

(put “x” in the box to select)

  • Dgo
  • PyDgraph
  • Dgraph4J
  • Dgraph-js
  • Dgraph-js-http
  • Dgraph.NET

Version: 21.3.2

What version of Dgraph are you using?


Have you tried reproducing the issue with the latest release?

What is the hardware spec (RAM, OS)?

Steps to reproduce the issue (command/config used to run Dgraph).

Use the guidance provided by the document, try to alter database, but failed with error.
client_stub = pydgraph.DgraphClientStub.from_cloud(“cloud endpoint url”, “<api_key>”)
client = pydgraph.DgraphClient(client_stub)
schema = ‘name: string @index(exact) .’
op = pydgraph.Operation(schema=schema)

Expected behaviour and actual result.

E0518 16:39:14.209293000 4668954112] Handshake failed with fatal error SSL_ERROR_SSL: error:1000007d:SSL
grpc._channel._InactiveRpcError: <_InactiveRpcError of RPC that terminated with:
status = StatusCode.UNAVAILABLE
details = “failed to connect to all addresses”
debug_error_string = “{“created”:”@1652906354.434495000",“description”:“Failed to pick subchannel”,“file”:“src/core/ext/filters/client_channel/”,“file_line”:3218,“referenced_errors”:[{“created”:"@1652906354.434495000",“description”:“failed to connect to all addresses”,“file”:“src/core/lib/transport/”,“file_line”:165,“grpc_status”:14}]}"

Experience Report for Feature Request

Note: Feature requests are judged based on user experience and modeled on Go Experience Reports. These reports should focus on the problems: they should not focus on and need not propose solutions.

What you wanted to do

What you actually did

Why that wasn’t great, with examples

Any external references to support your case

Tried with Rust client as well, not working, similar issue relating to gRPC.