Status = StatusCode.UNAVAILABLE details = “failed to connect to all addresses”

  File "/root/anaconda3/lib/python3.7/site-packages/pydgraph/txn.py", line 62, in query
    return self.do_request(req, timeout=timeout, metadata=metadata, credentials=credentials)
  File "/root/anaconda3/lib/python3.7/site-packages/pydgraph/txn.py", line 125, in do_request
    self._common_except_mutate(query_error)
  File "/root/anaconda3/lib/python3.7/site-packages/pydgraph/txn.py", line 222, in _common_except_mutate
    raise error
  File "/root/anaconda3/lib/python3.7/site-packages/pydgraph/txn.py", line 103, in do_request
    credentials=credentials)
  File "/root/anaconda3/lib/python3.7/site-packages/pydgraph/client_stub.py", line 57, in query
    credentials=credentials)
  File "/root/anaconda3/lib/python3.7/site-packages/grpc/_channel.py", line 826, in __call__
    return _end_unary_response_blocking(state, call, False, None)
  File "/root/anaconda3/lib/python3.7/site-packages/grpc/_channel.py", line 729, in _end_unary_response_blocking
    raise _InactiveRpcError(state)

grpc._channel._InactiveRpcError: <_InactiveRpcError of RPC that terminated with:
	status = StatusCode.UNAVAILABLE
	details = "failed to connect to all addresses"
	debug_error_string = "{"created":"@1605063370.883466162","description":"Failed to pick subchannel","file":"src/core/ext/filters/client_channel/client_channel.cc","file_line":3941,"referenced_errors":[{"created":"@1605063370.883454980","description":"failed to connect to all addresses","file":"src/core/ext/filters/client_channel/lb_policy/pick_first/pick_first.cc","file_line":393,"grpc_status":14}]}"

UNAVAILABLE 14 The service is currently unavailable. This is most likely a transient condition, which can be corrected by retrying with a backoff. Note that it is not always safe to retry non-idempotent operations.

Source: grpc/statuscodes.md at master · grpc/grpc · GitHub

Why not? Is there any solution?

If you share some context we could try to help. But what you have shown doesn’t help at all.

I’m so sorry that didn’t make myself clear.I’m using an Intranet server and running multiple Dgraph clusters with Docker,Now I want to access port 9080 of one of the Dgraph clusters externally.

Still not helps. Can you share the yaml? what you have done before this happens? can you share the code? is some node down?

I’ve solved it.Port problem.Thank you for your attention to this matter.