Unable to load bulk loaded data into Dgraph

I generated data from bulkloader using --reduce_shards=2 by following documentation at here

This generates 2 p directories on which I ran alphas following this link

Commands I used
dgraph zero --my=IPADDR:5080 on top directory

Then I cd to out directory and run one alpha on /0/p using dgraph alpha --lru_mb=4096 --my=IPADDR:7080 --zero=localhost:5080

If I check ratel at this point it’s all good

Then I cd to out directory and run second alpha on /1/p using dgraph alpha --lru_mb=4096 --my=IPADDR:7081 --zero=localhost:5080 -o=1

This runs fine, but data from this /1/p directory is not loaded, and ratel starts showing error in schema

Other 2 options I tried

I did bulk load using --reduce_shards=1 and just running one alpha, everything works fine

I stopped first alpha and ran alpha on /1/p the other predicates start showing up and it runs fine, but now /0/p data is gone

Are you using docker? This “IPADDR” do you let as it is or are you using real IP/Adress?

For docker I am replacing IPADDR with local ip addr, like and without docker setup I am replacing everything with localhost

Hey aishwat singh, you can use --reduce_shards set to 2 if you gonna have 2 Alpha groups. Otherwise is okay to use --reduce_shards=1 and paste the same output to all your alphas instances.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.