While applying proposal: Invalid address


(Ayeg) #1

Hello,
Just managed to configure docker to run my application based on this template (dockerfiles in that dir). https://github.com/tiangolo/full-stack/tree/master/{{cookiecutter.project_slug}}

At the moment I have my dgraph as part of the “base-images” together with db, which is postgres , and a Redis queue. To be honest, I’m still learning a lot of things about configuring docker and the backend so I’m probably missing something, but I’ve managed to get it working most of the time. The problem is that very often when I restart with docker-compose up, I start seeing a lot of errors like this:

zero_1_8c34f33df5ff | I1201 17:36:08.681764       1 zero.go:375] Got connection request: addr:"alpha:7080" 
zero_1_8c34f33df5ff | E1201 17:36:08.797171       1 raft.go:552] While applying proposal: Invalid address

I found that stopping everything and removing the volume is a good temporary fix right now, but I would like to find a proper way to prevent this.

this is what my dgraph settings look like in docker-compose.shared-base-images.yml.


zero:
      image: dgraph/dgraph:latest
      ports:
        - 5080:5080
        - 6080:6080
      restart: on-failure
      command: dgraph zero --my=zero:5080  
  alpha:
    image: dgraph/dgraph:latest
    ports:
      - 8080:8080 
      - 9080:9080
    restart: on-failure
    command: dgraph alpha --my=alpha:7080 --lru_mb=2048 --zero=zero:5080 
  ratel:
    image: dgraph/dgraph:latest
    ports:
      - 8008:8000
    command: dgraph-ratel
  allen_nlp:
    image: allennlp/demo:latest
    ports:
      - 8004:8000
    command: allennlp

I suspect I may need to put an Env Variable in place of alpha: or zero: , I’ve tried putting the host address but that doesn’t work. What should I be looking into to resolve this?

Br


(Daniel Mai) #2

This issue is fixed in the v1.0.11 release candidates. You can try with v1.0.11-rc4.


(Ayeg) #3

Changed to the newer version and now it’s been working without any issues after restarting, well done!