Dgraph on Cygwin/Windows not working

I am trying to install dgraph on cygwin and windows, although i get the message dgraph is already installed but the dgraph command is not working. Any inputs will be appreciated…

Hi @Abbas

Dgraph doesn’t work on Windows yet though we are planning to add support for it in a couple of weeks. Could you add an issue on Github so that this is tracked and fixed?

Sure, will do that, i guess till then i will need to use Virtualbox

@Abbas, I was able to install Dgraph on Windows 10 under Windows Subsystem for Linux. I recommend you try that instead of Cygwin if Cygwin isn’t working for you.

@Jeff, thanks for your suggestion, unfortunately i have Windows 7 and not Windows 10.

UPDATE:
i was able to run Dgraph using the Docker Toolbox for Windows.

Yeah, it works with the Docker toolbox as long as you don’t mount volumes (https://github.com/dgraph-io/dgraph/issues/1325). I am assuming you didn’t mount the volume @Abbas?

No i did not. I do not change any settings unless i am forced to…:slight_smile:

UPDATE:
I did mount the volume

1 Like

@pawan sorry for misunderstanding, i just saw the description of issue#1325, i did use the below command to run the docker image:

mkdir -p ~/dgraph
docker run -it -p 8080:8080 -p 9080:9080 -v ~/dgraph:/dgraph --name dgraph dgraph/dgraph dgraph --bindall=true

So, yes i did mount the volume and it is working fine for me.

Interesting, it might be a folder permission issue on my end. Thanks!

Hi @pawan, I was messing around, so I deleted dgraph docker container and deleted the related folders (since i found that the w directory and the MANIFEST file were still present there) and tried to install it through the below command:

mkdir -p ~/dgraph
docker run -it -p 8080:8080 -p 9080:9080 -v ~/dgraph:/dgraph --name dgraph dgraph/dgraph dgraph --bindall=true --memory_mb 2048

Now I am getting the same error as pointed out in Issue#1325 and i was able to make it run without mounting the volume as pointed out by you in the issue.

But the first time it did work and this is surprising.

the problem i am facing without mounting the volume is that i am unable to load rdf files using the dgraphloader command.

PS C:\Users\esgazai\dgraph> docker exec -it dgraph dgraphloader -r 1million.rdf.gz

Dgraph version : v0.8.1
Commit SHA-1 : d86498f7
Commit timestamp : 2017-08-16 12:53:17 +1000
Branch : HEAD

Processing 1million.rdf.gz
2017/08/18 05:18:57 open 1million.rdf.gz: no such file or directory

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.