Export Error Message

Report a Dgraph Bug

I received the following Export Error message when running
curl localhost:8080/admin/export?format=json

{“errors”:[{“message”:“Export failed.”,“extensions”:{“code”:“Export failed at readTs 3397396: cannot read posting list from this key”}}]}

when I check the export folder, I found the g01.json.gz file but the g01.schema.gz file is empty.

Is there a way to separately export the schema?

What version of Dgraph are you using?

Dgraph version : v1.2.1
Dgraph SHA-256 : 3f18ff84570b2944f4d75f6f508d55d902715c7ca2310799cc2991064eb046f8
Commit SHA-1 : ddcda9296
Commit timestamp : 2020-02-06 15:31:05 -0800
Branch : HEAD
Go version : go1.13.5

Have you tried reproducing the issue with the latest release?
I was planning to export first to try the latest release but if I cannot export, I am stucked.

What is the hardware spec (RAM, OS)?
Ubuntu, not sure how to check the RAM but it should be the default 4096 allocated.

Steps to reproduce the issue (command/config used to run Dgraph).
as above.

@martinmr is this a known bug?

Since the export isn’t working for you, how about querying for schema curl "http://localhost:8080/query" -d 'schema {}' -s -H "Content-Type: application/graphql+-" ?

However, I don’t think all your data was exported since data and schema export happen at the same time.


Can I ask is there a way for me to debug this error code:
Export failed at readTs 3397396:

so that I can export successfully?

@martinmr any ideas on how to debug this?

I think this is a known bug that’s already been fixed in the latest 1.2 release.

@M.Lau I think you can try running Dgraph 1.2.6 with your data and doing the export. The two versions should be compatible in terms of the data so there’s no need to export/import your data first in order to switch versions. But backup your data before you do this just in case.

1 Like

Ah yes, it worked!

Thanks very much.

1 Like