The host cannot access the virtual machine's docker image,

bug

(Jiang320) #1

local host :10.0.x.x
my virtual machine ip:192.168.88.21
my docker ip: 172.17.0.1
dgraph version :latest
i can connect dgraph-ratel from browser of the virtual machine.
I can ping docker service from host machine’s powershell.
However,can’t connect http://192.168.88.21:8000 from host’s chrome browser.


(Michel Conrado) #2

Hi Jiang.

Well I can’t see how to help you. If you’re following the docs to run Ratel’s image, you should be able to do it without any problem.

Can you try to run any other image? like Ghost. I mean, there’s any other service you can reach from the host?

Cheers.


(Jiang320) #3

thank you for your replying.
you remind me of “Ghost”,though I don’t know how to do next .
I try to create other Linux virtual machine in the same VMware Workstation.
the linux IP is 192.168.88.44.
I try to connect the dgraph in another VM (ip :192.168.88.21).it is ok.

my host run Windows 10 OS,this maybe the issue .
but when I run dgraph0.7.7,I can connect the dgraph in the host brower.

windows os is a problem


(Jiang320) #4

I had solved the problem.I used the proxy,so http connection is not available in my host.