Telemetry superflag not recognized


Report a Dgraph Bug

What version of Dgraph are you using?

Dgraph Version

With Docker image dgraph/standalone:v21.12.0

$ + docker compose run dgraph dgraph version

Dgraph version   : v21.12.0
Dgraph codename  : zion
Dgraph SHA-256   : 078c75df9fa1057447c8c8afc10ea57cb0a29dfb22f9e61d8c334882b4b4eb37
Commit SHA-1     : d62ed5f15
Commit timestamp : 2021-12-02 21:20:09 +0530
Branch           : HEAD
Go version       : go1.17.3
jemalloc enabled : true

For Dgraph official documentation, visit https://dgraph.io/docs.
For discussions about Dgraph     , visit https://discuss.dgraph.io.
For fully-managed Dgraph Cloud   , visit https://dgraph.io/cloud.

Licensed variously under the Apache Public License 2.0 and Dgraph Community License.
Copyright 2015-2021 Dgraph Labs, Inc.

Have you tried reproducing the issue with the latest release?

Yes, this is the latest release.

What is the hardware spec (RAM, OS)?

Irrelevant.

Steps to reproduce the issue (command/config used to run Dgraph).

$ docker \
  compose \
  run \
  dgraph \
  dgraph \
  live \
  --telemetry 'reports=false; sentry=false;'

Expected behaviour and actual result.

The docs show the superflags, but what positions to put them at remains unclear.
As for --telemetry, this superflag does not have its own heading.

Error: unknown flag: --telemetry

Any external references to support your case

https://dgraph.io/docs/deploy/cli-command-reference/#security-superflag