ACL Account error

I need to use ACL account for login verification. This is a new cluster that I created, but it displays " This server has unrestricted access (Access Control Lists are disabled)" on Retal.


Check these docs to activate the ACL

Hi @MichelDiz I run dgraph through docker ,and I don’t have a LICENSE_KEY

I’m using version 20.03,By the way, the dgraph deployed before does not need ‘dgraph zero enterprise’_ license=PATH_ TO_ LICENSE_ Key ',and can carry on 30 day enterprise edition experience

ACL is an enterprise feature, but you have 30 days to test it.

You don’t need to insert the --enterprise_license. Just use the “Enabling ACL” part.

By the way,How can I check the creation time of the cluster and the service life of the enterprise version

Via Ratel, you go to Cluster panel and check there for “Expires: in XX days”.
The creation time is a value in seconds that you need to do a conversion. That you can found in ‘localhost:8080/state’ I think.

Thank you @MichelDiz for your attention to this matter.

1 Like

Hi @MichelDiz ,I have a new problem,In order to solve the problem:

I tried this link

However, I found Enabling ACL mentions the need for secret key,how can I get this key?

Is this part available only by paying for the enterprise version?

You need to pay for an enterprise license for ACL.

According to the official document, it can be used for 30 days for free. I just want to experience the ACL related functions :rofl:

I use local for ACL verification, and this happens

Authentication from address failed:unable to authenticate through password user not found for id groot

It is a plain text, can be anything. Here is an example ratel/acl-secret.txt at master · dgraph-io/ratel · GitHub

You can login with groot which has the default password as “password”.

I just follow the account “groot” and password “password”,the error message is like this:
Authentication from address failed: unable to authenticate through password: user not found for id groot

By the way, is there a coding format requirement for plain text?

Try this or start from scratch again. But before doing anything, when you start the Cluster, wait 1 minute before doing anything. Just in case.

Forget to say, in my visit localhost:8080/admin When you do, you will report an error :cry:

{“errors”:[{“message”:“Request from IP:”,“extensions”:{“code”:“ErrorUnauthorized”}}]}

By the way, is there a coding format requirement for plain text?

What version are you using?

Yeah, You need to be logged.

I’m using v20.03
I tried to start with docker-compose,alpha restarting


Would you mind to upgrade? We had issues with login in Ratel UI and fixed others in the ACL part. If you are starting now, you should start with the latest.

Well, at present, I am using v20.03 for production data management. I need to verify the ACL function to adapt to the existing version. If I upgrade, it is not friendly to me :cry:
In that case, I still face the problem of importing a lot of data.For some reasons, I have to use pydgraph to import data into dgraph.What makes me sad is that it takes a long time to import a large amount of data . Every time it import data one by one :rofl:

I got this advice in the community, but I haven’t found a way to upload multiple nodes for per mutation.

Thank you @MichelDiz for your help. I’ve solved the problem.

1 Like