ACL Helm chart

We have deployed the latest version of Dgraph cluster using Helm chart.
We are able to open the ratel UI. But the ACL function is not available for us.

We also tried the ACL helm method mention in this blog

Here are the screenshots for your reference

Let me know if you want any further information or Is there something that we are missing.

You should follow the first link in this conversation. The helm chart may have some way to enable ACL.

ping - @joaquin

We tried the first link solution. But still we are facing with the same error. We are not sure how to proceed further.

Can you explain what exactly the problem is? The post had several situations.

The helm has examples like

Yes, we have mentioned the hmac secret file in the same manner.
We are deploying latest helm chart. We are mentioning the hmac secret in values.yaml.
After deployment, we cannot take a backup, log in using the default username and password.
The data is also not getting stored in the database. We see 0 Bytes in the cluster option of the ratel UI.
Here is an image for your reference.

Sure, let me try on my end with my local k8s and see if I fail to do the same.
Maybe @joaquin could help faster than me. Cuz it will take some time to create the scenario and I’m working in other stuff and helping others too. So it will take time.


Hey Kunal.

I was able to set up a local cluster with helm and ACL as the mentioned steps.

I did

vim dgraph_values.yaml

    enabled: true
      hmac_secret_file: MTIzNDU2Nzg5MDEyMzQ1Njc4OTAxMjM0NTY3ODkwMQo=
    config.yaml: |
        secret_file: /dgraph/acl/hmac_secret_file

then I did

helm install “michel-dgraph-acl” --values ./dgraph_values.yaml dgraph/dgraph

And I got from the Alpha logs

I0516 01:45:35.103446      20 run.go:811] ACL secret key loaded successfully.

And from Ratel I got

Logged in as **groot**

Namespace: 0

All good.

Are you running k8s where? cloud? locally? some custom stuff?

I’m running it on k8s.
I have also mentioned the exact thing as you are doing

We reached a dead end. Try to redo all the steps from scratch. it worked for me on a clean instance.