Azure Docker Container

I attempted to create an Azure Docker Container (ACI) using the dgraph/dgraph:latest image. The container started and was immediately killed… tried this multiple times with different images. Eventually, I used dgraph/dgraph:standalone:v21.03.0 and this one worked.

Q1: How can I get the dgraph/dgraph:latest server container working on Azure Docker?

Q2: How can access the Azure image through Ratel? It does not seem to connect (first stop-light is red in the connection bar).

Thanks for any guidance!

You have to run the instance command. See the DQL Tour A Tour of Dgraph

You have to expose the ports. Be it on Docker or Azure firewall or something like this.

Michel - thanks for you reply. I see your name all over the forum!

A had gone through the DQL tour thoroughly. Did not see anything related to Docker deployment or the instance command. Any chance you could point me to the right doc page?

It happens :stuck_out_tongue:

Using Docker commands.

# Run Dgraph zero
docker run -it -p 5080:5080 -p 6080:6080 -p 8080:8080 \
  -p 9080:9080 -p 8000:8000 -v ~/dgraph:/dgraph --name dgraph \
  dgraph/dgraph:v21.03.0 dgraph zero

# In another terminal, now run Dgraph alpha
docker exec -it dgraph dgraph alpha --cache size-mb=2048 --zero localhost:5080 --security whitelist=