Can't load a bigger dataset: https://dgraph.io/tour/moredata/1/#

image

Trying to load the data. Before these commands, I ran the commands in Run Dgraph | Intro | Dgraph Tour, then ran the schema command in the tour.

Hum, windows is a bit tricky. This can be related to the way PowerShell deals with paths. Try to use CMD instead. (I’ll check what is happening and what we can do for PowerShell).

1 Like

Unfortunately it didn’t work on CMD either. Thanks though!

ohhh, I see, it is “docker exec”. it is not related to Windows. So, you have to pass/copy those files to the container. Or you can docker exec to that container and clone the files there instead. Also, you have to make sure that you are doing the whole process in the right path inside the container.

1 Like

I used docker cp to copy the dataset into the dgraph container, then started the container and alpha and all that, and unfortunately I still get the same error :frowning:

Do the following.

docker exec -it dgraph sh

And then

curl -L -o 1million.rdf.gz "https://github.com/dgraph-io/tutorial/blob/master/resources/1million.rdf.gz?raw=true"

Run

ls && pwd

You should get

1million.rdf.gz  p  w  zw
/dgraph

Now you can just run (But remember to add the schema)

dgraph live -f 1million.rdf.gz --alpha localhost:9080 --zero localhost:5080 -c 1

Now you can just exit

exit
1 Like

Wow, thanks for taking your time to explain all this. Cheers!

1 Like