Trouble loading 1M dataset

Hello mrjn,I am new to here and I am not sure if this is the right place to ask.Also I’m not an english speaker so please forgive me for my bad english lol.I get into trouble with loading the 1million.rdf.gz data for a begniner.I run my Dgraph in docker on win10, and when I use git bash :[docker exec dgraph_server_1 dgraph live -r 1million.rdf.gz --zero=zero:5080 -c 1], it doesn’t work.
the tip is:[ open E:/Dgraph/1million.rdf.gz: no such file or directory
] I think I put it in the wrong dir but I’m not sure where should I put it. Really thanks for any help here.

I’m in the same situation. (And I wish was good at any language other than English as you are in English! )

I think the problem is not knowing how to get the docker container to have/see/have access to the file.

One trick, I think, is that the sample documentation is saying port 5080 but I think the server in all the other example contexts is 8080. So, either there is a different port for that particular command or the sample documentation is out of date/referring to the wrong port.

Anyone with experience help us both out with getting the 1million rdf loaded?

Dave G

@David Gerding
Hi,I finally had solved the problem, I guess it’s about [file in the local dir can’t be read by the program running in the docker]. Here is what I did:I was trying to copy my 1million.rdf into the docker using [ docker cp ./1million.rdf.gz dgraph_server_1:/dgraph
] and [ docker cp ./1million.rdf.gz dgraph_server_1:~], I used both of it lol, and then it worked.

1 Like