Can't start dgraph with docker

I Want to Do

start dgraph docker container

What I Did

the docker command I run is:
docker run -dit --network hdl_admin -v /d/dgraph_data:/dgraph --network-alias admin -p 8080:8080 -p 9080:9080 -p 8000:8000 --name hdl_admin dgraph/standalone:latest

first time I run it successfully, but after some create and rm the container, the bug below come up. And I run docker rm hdl_admin and run create command same as before, it can’t start the container.

I have mount /dgraph to the D://dgraph_data folder, but I didn’t change anything of it.

Dgraph Metadata

 Dgraph version   : v20.11.0
 Dgraph codename  : tchalla
Dgraph SHA-256   : 8acb886b24556691d7d74929817a4ac7d9db76bb8b77de00f44650931a16b6ac
 Commit SHA-1     : c4245ad55
Commit timestamp : 2020-12-16 15:55:40 +0530
Branch           : HEAD
Go version       : go1.15.5
jemalloc enabled : true

I run docker logs -f -t hdl_admin, the panic report is:

2021-02-15T02:12:19.828970900Z I0215 02:12:19.828261      36 node.go:326] Group 1 found 386 entries
2021-02-15T02:12:19.828988000Z I0215 02:12:19.828307      36 draft.go:1689] Restarting node for group: 1
2021-02-15T02:12:19.828997700Z I0215 02:12:19.828321      36 node.go:189] Setting conf state to nodes:1
2021-02-15T02:12:19.829006500Z 2021/02/15 02:12:19 1 state.commit 387 is out of range [73, 386]
2021-02-15T02:12:19.845496500Z panic: 1 state.commit 387 is out of range [73, 386]
2021-02-15T02:12:19.846171100Z goroutine 167 [running]:
2021-02-15T02:12:19.846182500Z log.Panicf(0x1dae9fb, 0x2b, 0xc000531240, 0x4, 0x4)
2021-02-15T02:12:19.846191100Z  /usr/local/go/src/log/log.go:358 +0xc5
2021-02-15T02:12:19.846199100Z*ToGlog).Panicf(0x2dffcb8, 0x1dae9fb, 0x2b, 0xc000531240, 0x4, 0x4)
2021-02-15T02:12:19.846206200Z  /ext-go/1/src/ +0x53
2021-02-15T02:12:19.846213500Z*raft).loadState(0xc00060ac80, 0x3, 0x1, 0x183, 0x0, 0x0, 0x0)
2021-02-15T02:12:19.846220700Z  /go/pkg/mod/ +0x1c4
2021-02-15T02:12:19.846228100Z, 0x180)
2021-02-15T02:12:19.846235100Z  /go/pkg/mod/ +0xd55
2021-02-15T02:12:19.846242300Z, 0x1, 0xc00052a350)
2021-02-15T02:12:19.846250000Z  /go/pkg/mod/ +0x45
2021-02-15T02:12:19.846358700Z  /ext-go/1/src/ +0x437
2021-02-15T02:12:19.846370800Z, 0x1)
2021-02-15T02:12:19.846378400Z  /ext-go/1/src/ +0x745
2021-02-15T02:12:19.846393300Z  /ext-go/1/src/ +0x3c
2021-02-15T02:12:19.846400600Z created by
2021-02-15T02:12:19.846407600Z  /ext-go/1/src/ +0x12c5
2021-02-15T02:12:19.846415200Z W0215 02:12:19.845971      10 sentry_integration.go:140] unable to read CID from file /tmp/dgraph-alpha-cid-sentry open /tmp/dgraph-alpha-cid-sentry: no such file or directory. Skip
2021-02-15T02:12:19.895385300Z [Sentry] 2021/02/15 02:12:19 Sending fatal event [68dc6ef1d4b642e782bb8218ff600c56] to project: 1805390
2021-02-15T02:12:21.895723800Z [Sentry] 2021/02/15 02:12:21 Buffer flushing reached the timeout.

Looks like the same case State.commit is out of range - #2 by MichelDiz

Oh,yes. It’s the same problem.I delete the w folder, then it run successfully, thanks!