Dgraph Ratel connection issue on EC2 instance

A new EC2 instance has been setup and I have followed steps provided at following link for linux: https://dgraph.io/downloads

I am able to get the alpha, zero and ratel instance up. The issue is while trying to access ratel UI.
The UI loads but connection is not established.

Being new to dgraph, it is possible I may have missed a configuration.
Any help will be appreciated. DO let me know if more details are required to understand the issue

The Ratel UI must connect to the Alpha server’s ip:port. The port is typically 8080.

In your case, it seems it is 8000 which is the Ratel’s port and is incorrect.

Thanks for the prompt response. That was the issue. re-pointing it to 8080 solved the issue.

1 Like

I ran into this as well and quickly fixed it with providing the correct port. It would be nice for it to see that it is trying to use port 8000 and auto change to port 8080, but then again, some people could map port 8080 to whatever port they wanted to.

I have decided to run ratel locally instead of from the server though to save on server resources.