Ratel Installer for Linux, MacOs and Windows (UPDATED 2020)

Hello everyone,

UPDATE (2020):

The old links that you download the Ratel’s old version won’t work on the latest releases.

I have builded new versions here https://drive.google.com/drive/folders/1YpvBtfKYLgtlZebH3qhaFQRS0rymXtZX?usp=sharing
It has Windows, Linux and Mac os. Let me know if it is broken on your system. Cuz I have tested only on macOS.

I’m posting a preview version of Ratel Dashboard for Windows, Linux, and macOS platforms. It’s not official, just a preview. This version will serve as an extra extension tool, along with the official Dgraph binary.

NOTE: Old information below.

47

Release notes:

  • Option to send JSON objects via mutate.
    See reference: Update: Using JSON to mutate on Dgraph. (cURL, Raw HTTP)
  • added “copy JSON resp” to clipboard.
  • Each frame (mutate, alter, query) is logically separated.
  • New Dgraph cleanup option via “Drop all” added to the “Manage Schema” frame.
  • Types Updates in “Add predicate” (upsert, lang and so on).
  • Improved ordering on Manage Schema.

Installers:

Windows (W10):


MacOS (HighSierra tested):

Linux (Fedora tested):
.deb - https://drive.google.com/open?id=1KITDsmUQwY3vcNKPFj6nm6iltBBDTjm1
.tar.gz - https://drive.google.com/open?id=1euEu3jB_X5eEnFnyv03hOu6HSC28bZrp

Prints:

7 Likes

Nice work Michel! This looks awesome.

2 Likes

Nice work Michel! This looks awesome.

1 Like

hi, Michel, When I run the query
{
test(func: has(name)){
uid
name
}
}
,there is a error message “Unsupported Content-Type, Supported content types are application/json, application/graphql±”, but the content type is indeed application/graphql±, I don’t know what’s wrong? thanks

when I click the button “Manage Schema”, the error message is “Error While trying to fetch schema”, but I have already connected the server

Sorry Kavin, this version is too old. It can’t run on the latest Dgraph. I can rebuild it, but it will take time. Cuz, also, Ratel has changed a lot.

thanks, I really need a local client,the official web client is difficult to connect,there is a problem here. When I open it, I will be prompted to read a certain file on the C drive, but my computer is the company’s computer. The C drive is protected and cannot be operated. thanks again.

hi,Michel, are you already rebuilding the client? :grinning: :grinning: How I wish I could see it as early as possible!

It will take time. As Ratel has changed a lot I have to start from scratch.

Can we get a Ratel iOS App :sweat_smile:

Thanks very much

Good news, I have worked on porting Ratel to the latest version to Electron. I have edited the main comment with the link to download. Please, test it and let me know if it is working for you. Also, I gonna update the Electron branch on Ratel’s repository.

Cheers.

3 Likes

It’s really a good news :grinning:, Thanks very much @MichelDiz

Slash supports Ratel now, but I guess this version of Ratel is older, because it doesnt have the field to enter an API key.

1 Like

Yes, is a bit behind master. The electron branch is here https://github.com/dgraph-io/ratel/tree/ElectronJS if you wanna these commits you can merge master and build it locally. I can do it with free time, but have to wait.

2 Likes