Unable to get slash-graphql cli to work

I was busy for a few days (weeks) and when I finally made changes and ready to update the lambda, I am getting all sorts of errors. First, the Authentication for cli was changed, I was using direct google login so had to use a different account email with password. but even after doing that, when I try to update the lambda I am getting an error:


slash-graphql update-lambda -e REDACTED -f=./lambda.js


    TypeError: first argument must be a string or instance of Error
error Command failed with exit code 1

What should I do ? updating schema works fine, I am logged in with the CLI (with email and password).


I tried to update using the Cloud UI and there I get the following error:

Not Authorized to update the Deployment: 0x20b75

I am the owner of that backend. Is there any problems going on ?

Sounds like they haven’t figured out the future of automation yet:

Several posts with this issue:

I imagine this is at the top of their list. However, updating Dgraph Cloud to 21.03 without problems is probably number 1 for the moment.


so there is no solution right now ? March 25 was a while ago, I saw those posts but I thought this should have been fixed by now and I don’t know the solution.

Retrying with cloud UI did finally update my lambda but I had to set a password to gmail account (using reset password route) and then login to UI with email and password. not really sure if that is what fixed it.

Also looks like that as an owner I can update the lambda using the UI but other members of my organization are not able to update it. even when using the UI.

and this used to work fine, so can’t you just roll back to give us what was working already?

Please also note whoever is owning this, if you are still evaluating the CLI usage. if there is no CLI we will almost certainly move away. it is not optional, it is Essential for us.