My present version is 1.0.15 need to upgarde it to latest, can u help me out

what do u mean by an empty schema file, will you elaborate please,

Not an open data set

Just a file pretending to be a .schema nothing more.

it worked MichelDiz, data imported

Thanks a lot MichelDiz…

2 Likes

After performing queries in ratel-ui, i am not get data

Have you followed this? https://dgraph.io/docs/deploy/dgraph-administration/#upgrading-from-v122-to-v20030-for-enterprise-customers

You are using a very old version. Several things have changed since then. Sorry about that, but as It is an old fact, I thought that you were aware of it. You have to modify your dataset. Fortunately, it is possible to do this using the Upsert Block.
e.g:

upsert {
  query {
    v as var(func: has(username))
  }

  mutation {
    set {
      uid(v) <dgraph.type> "User" .
    }
  }
}

You can use the upsert to introduce the “dgraph.type”. This is part of the Type System. Read this https://dgraph.io/docs/query-language/type-system/#type-definition

Also, you have to modify the Schema.
e.g:

type User {
    name
    age
    somethingelse
}

name: string @index(exact) .
age: int .
somethingelse: string .

But, are you sure you have this data that you have queried? feels like it should be able to query for it. It doesn’t seems related to the Type System as I see now.

I look in to that MichelDiz, Thanks for your continuous support.

1 Like

After importing data with empty schema files, if i check in schema some predicates with type uid is list.
but with our actual data uid are not list. and also indices also not imported.

can u sort out this issue

You can give a minimum schema, that covers only the predicates you wish not set automatically as default. All UIDs are [uid] by default.

how to pass that minimum schema

The same way you have pass the empty one.

will u please eleborate … i want step by step process

I will eloborate my issue in detail

if i pass schema file which i exported, during bulk process i am facing error with schema is not matching.
Then i passed an empty schema file, data imported .
Now the issue is indices are not imported for predicates and in my previous version 1.0.15 type :uid are not list, but in the latest it is type : uid is list.

  1. Select all predicates that you need to be fixed and fix it.
  2. Create a TXT file called schema.txt (can be any type of text file) and put the predicates there.
  3. Start the Bulk dgraph bulk -s schema.txt ...

Again it is showing the same error

There’s no way to fix that specific error without sanitation in your dataset. You need to find out what is happening.

  1. Check your dataset directly via some text editor or grep
  2. Or you can remove all predicates that has boolean from the schema.txt . And ignore this error.

This error is other thing. I have give to you a solution for the uid list issue. In the end, you gonna have to check your dataset anyway. That’s what I recommend. Understand why this is an empty string in a Boolean type.

Hi MichelDiz,

I am Running Dgraph V20.07.3 on Kubernetes
I am accessing dgraph through LoadBalancer IP… i mean ratel UI.
Now, I want restrict the access to Ratel UI. How can I do that … is there password based authentication? OR TLS?
Can u help out…

Right now we don’t support this. In the future we gonna have a kind of password via HTTP. With a single “user” called Poor man’s ACL. I recommend that you don’t expose your cluster. Create a tunnel, a VPN or something to connect with Dgraph using Ratel.

Also, there are reverse proxies out there that you can put a simple authentication on top of it. But we don’t give support to it. It is up to you. Also, third parties authentication would not work with Ratel.

If you gonna use GraphQL, things get simple. Put the cluster behind a firewall and expose only :808/graphql - And use the Auth (free feature) that comes with GraphQL. But to use DQL via Ratel and manage the cluster you have to have a VPN, tunnel or something.